49 10 94 44 021
82 09876 0912
روزهای شنبه الی چهارشنبه از ساعت ۱۰ الی ۲۰

مرکز آموزش میکروتیک

مجری برگزاری دوره ها و آزمون های بین المللی میکروتیک
آموزش میکروتیک
۱۳ فروردین ۱۳۹۹

آموزش میکروتیک – باز کردن سایت یوتیوب Youtube بوسیله میکروتیک

در این آموزش ویدیویی یاد میگیرید که چطوری بوسیله دستگاه میکروتیک بصورت حرفه ایی و بهینه به وب سایت یوتیوب ( Youtube ) دسترسی پیدا کنید بدون اینکه کلیه آدرس ها و رنج های آیپی شرکت گوگل را به میکروتیک اضافه کنید , ضمن اینکه با این مکانیزم قادر خواهید بود به کلیه سایتهایی که فیلتر هستند دسترسی برقرار نمایید , کد ها و دستورات مورد نیاز در انتهای صفحه قرار دارد.

پیشنهاد میکنیم ابتدا ویدیو اول با عنوان تشریح سناریو رو به دقت مشاهده نمایید , سپس ویدیو دوم کانفیگ میکروتیک رو مشاهده کنید.

ویدیو اول – تشریح سناریو

ویدیو دوم – کانفیگ میکروتیک

دستورات اسکریپت استفاده شده در ویدیو :

:foreach i in=[/ip dns cache find name~"ggpht"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get $i address]; } on-error={} }

:foreach i in=[/ip dns cache find name~"ggpht"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get $i name]; } on-error={} }

:foreach i in=[/ip dns cache find name~"googlevideo"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get $i address]; } on-error={} }

:foreach i in=[/ip dns cache find name~"googlevideo"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get $i name]; } on-error={} }

:foreach i in=[/ip dns cache find name~"youtube"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get $i address]; } on-error={} }

:foreach i in=[/ip dns cache find name~"youtube"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get $i name]; } on-error={} }

:foreach i in=[/ip dns cache find name~"ytimg"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get $i address]; } on-error={} }

:foreach i in=[/ip dns cache find name~"ytimg"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get $i name]; } on-error={} }


دستورات مورد نیاز و کانفیگ های لازم :

۱. دستورات استفاده کردن از DoH – DNS Over HTTPs در میکروتیک

ip dns set allow-remote-requests=yes servers=8.8.8.8,4.2.2.4 use-doh-server=https://cloudflare-dns.com/dns-query

۲. دستورات استفاده کردن از DNS Proxy بدون DoH

ip dns set allow-remote-requests=yes servers=8.8.8.8,4.2.2.4


۳. دستورات مورد نیاز سرویس VPN و Policy Based Routing ( فیلد های مربوط به ارتباط VPN را با تنظیمات صحیح خود اکانت VPN خود تکمیل کنید )

interface l2tp-client add connect-to=YOUR-VPN-SERVER-ADDRESS disabled=no ipsec-secret=YOUR-IPSEC-SECRET name=VPN password=YOUR-VPN-PASSWORD use-ipsec=yes user=YOUR-VPN-USERNAME

ip route add distance=1 gateway=VPN routing-mark=VPN

ip firewall nat add action=masquerade chain=srcnat out-interface=VPN


۴. دستورات Policy Based Routing جهت عبور ترافیک DNS از روی تانل

ip firewall mangle add action=mark-routing chain=output dst-address-list=DNS dst-port=53 new-routing-mark=VPN passthrough=yes protocol=udp

ip firewall address-list add address=4.2.2.4 list=DNS

ip firewall address-list add address=8.8.8.8 list=DNS


۵. دستورات Policy Based Routing جهت عبور ترافیک یوتیوب ( Youtube ) از روی تانل

Ip firewall mangle add action=mark-routing chain=prerouting dst-address-list=Youtube new-routing-mark=VPN passthrough=yes


۶. دستورات اسکریپت مورد نیاز جهت پیدا کردن آیپی های یوتیوب و افزودن به آدرس لیست

system scheduler add interval=1s name=Youtube on-event=":foreach i in=[/ip dns cache find name~\"ggpht\"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10\
    :۰۰ address=[/ip dns cache get \$i address]; } on-error={} }\r\
    \n\r\
    \n:foreach i in=[/ip dns cache find name~\"ggpht\"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get \$\
    i name]; } on-error={} }\r\
    \n\r\
    \n:foreach i in=[/ip dns cache find name~\"googlevideo\"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache \
    get \$i address]; } on-error={} }\r\
    \n\r\
    \n:foreach i in=[/ip dns cache find name~\"googlevideo\"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache \
    get \$i name]; } on-error={} }\r\
    \n\r\
    \n:foreach i in=[/ip dns cache find name~\"youtube\"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get \
    \$i address]; } on-error={} }\r\
    \n\r\
    \n:foreach i in=[/ip dns cache find name~\"youtube\"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get \
    \$i name]; } on-error={} }\r\
    \n\r\
    \n:foreach i in=[/ip dns cache find name~\"ytimg\"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get \$\
    i address]; } on-error={} }\r\
    \n\r\
    \n:foreach i in=[/ip dns cache find name~\"ytimg\"] do={ :do { /ip firewall address-list add list=Youtube timeout=00:10:00 address=[/ip dns cache get \$\
    i name]; } on-error={} }\r\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=mar/31/2020 start-time=16:35:15